--------(--)

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

2013-04-13(Sat)

R Gtk2 configure: error: GTK version 2.8.0 required on Ubuntu12.04 LTS

RRGtk2パッケージをインストールしてみたら依存関係エラーが発生した。

> install.packages("RGtk2")
Installing package(s) into ‘/usr/local/lib/R/site-library’
(as ‘lib’ is unspecified)
URL 'http://cran.ism.ac.jp/src/contrib/RGtk2_2.20.25.tar.gz' を試しています
Content type 'application/x-gzip' length 2784794 bytes (2.7 Mb)
開かれた URL
==================================================
downloaded 2.7 Mb

* installing *source* package ‘RGtk2’ ...
** パッケージ ‘RGtk2’ の解凍およびMD5サムの検証に成功しました
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for INTROSPECTION... no
checking for GTK... no

configure: error: GTK version 2.8.0 required
ERROR: configuration failed for package ‘RGtk2’
................
* removing ‘/usr/local/lib/R/site-library/RGtk2’
Warning in install.packages :
installation of package ‘RGtk2’ had non-zero exit status

The downloaded source packages are in
‘/tmp/Rtmpn65OzB/downloaded_packages’


configure: error: GTK version 2.8.0 required
ここから推測するとGTKのdevとか入れないとあかんのかな?
と思ってググるとここにlibgtk2.0-devが必要と書いてある。

$ sudo apt-get install libgtk2.0-dev


で解決した。
関連記事
スポンサーサイト

コメントの投稿

管理者にだけ表示を許可する

コメント

プロフィール

kumagonjp2

Author:kumagonjp2
Python,Django,R,Mongo,MySQL,Struts,Spring,データマイニングなどサーバー関係のメモを残していきます。

最新記事
最新コメント
最新トラックバック
月別アーカイブ
カテゴリ
雪が3Dで降るブログパーツ ver2

マウスで見る方向変えられます

検索フォーム
RSSリンクの表示
リンク
ブロとも申請フォーム

この人とブロともになる

QRコード
QR
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。